configure does not correctly identify some items

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

configure does not correctly identify some items

gregory.wolfe
I have already worked around this problem by editing config.h after
running configure, so the purpose of this note is informational only
(can't fix it if you don't know about it).

I am building the lame-3.99.5 version of libmp3lame-0.dll for the purpose
of including it in the latest FFmpeg build (upgrading both from older
versions).  I am using a MinGW environment on Windows 7.  After running
configure, the build failed for the following reasons:

        - bad typedefs for signed/unsigned 32/64 bit integers (e.g.,
int32_t)

        - did not detect presence of strchr, memcpy, and limits.h

The build worked after I edited config.h so that it contained the
following:

        typedef int int32_t;
        typedef long long int64_t;
        typedef unsigned int uint32_t;
        typedef unsigned long long uint64_t;

        #define HAVE_STRCHR 1
        #define HAVE_MEMCPY 1
        #define HAVE_LIMITS_H 1

I was under the impression that the whole point of using the configure
script was to avoid having to make manual edits like this.  Am I missing
something here?

Please let me know if you want more detailed information.  Thanks for
listening.

Greg Wolfe
Kodak Alaris
------------------------------------------------------------------------------
WatchGuard Dimension instantly turns raw network data into actionable
security intelligence. It gives you real-time visual feedback on key
security issues and trends.  Skip the complicated setup - simply import
a virtual appliance and go from zero to informed in seconds.
http://pubads.g.doubleclick.net/gampad/clk?id=123612991&iu=/4140/ostg.clktrk
_______________________________________________
Lame-dev mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/lame-dev